电子邮件 RFC 参考
互联网电子邮件的每个RFC的完整指南。SMTP、DKIM、SPF、DMARC、MIME、TLS等——为开发者讲解。
Core SMTP & Message Format
RFC 1869
RFC 1869 – SMTP 服务扩展 (ESMTP)
RFC 2920
RFC 2920 – SMTP 流水线处理
RFC 3030
RFC 3030 – SMTP 二进制MIME和分块
RFC 5321
RFC 5321 – 简单邮件传输协议
RFC 5322
RFC 5322 – 网络邮件格式
RFC 5598
RFC 5598 – 互联网邮件架构
RFC 6409
RFC 6409 – 邮件消息提交
RFC 6531
RFC 6531 – 国际化电子邮件的SMTP扩展
RFC 6532
RFC 6532 – 国际化电子邮件头
Email Authentication
RFC 7208
发送方策略框架(SPF)
RFC 6376
域名密钥识别邮件(DKIM)签名
RFC 7489
基于域名的消息认证、报告和一致性(DMARC)
RFC 4954
RFC 4954: SMTP 认证扩展
RFC 5617
作者域签名实践
RFC 8463
RFC 8463: 用于 DKIM 签名的 Ed25519
RFC 8601
身份验证结果标头字段
RFC 7489
基于域的邮件身份验证、报告和符合性
RFC 8617
认证接收链
RFC 7208
发件人政策框架
RFC 6376
域名密钥识别邮件
Transport Security
RFC 3207
RFC 3207 – SMTP STARTTLS 扩展
RFC 7817
RFC 7817:电子邮件的更新型TLS服务器身份检查
RFC 8314
RFC 8314:明文已过时
RFC 8689
RFC 8689: SMTP 要求 TLS 选项
RFC 8461
邮件传输代理严格传输安全
RFC 7672
基于DNS的SMTP TLS身份验证
MIME — Multipurpose Internet Mail Extensions
RFC 2045
互联网信件体格式
RFC 2046
RFC 2046:MIME 第2部分——媒体类型
RFC 2047
非ASCII文本的消息头扩展
RFC 2049
RFC 2049:MIME 第 5 部分——符合性准则和示例
RFC 2231
RFC 2231:MIME 参数值扩展
Delivery Status & Bounce Handling
RFC 3461
RFC 3461: SMTP投递状态通知扩展
RFC 3462
RFC 3462: 多部分/报告内容类型
RFC 3463
RFC 3463: 增强邮件系统状态代码
RFC 3464
RFC 3464: 投递状态通知格式
RFC 5248
RFC 5248: SMTP 增强状态代码注册表
RFC 6522
RFC 6522:Multipart/Report 媒体类型(已更新)
Abuse Reporting & Feedback
RFC 5965
滥用报告格式
RFC 6591
RFC 6591:认证失败报告(AFRF)
RFC 6652
RFC 6652: SPF 身份验证失败报告
RFC 8460
RFC 8460: SMTP TLS 报告 (TLSRPT)
Mailing Lists & Header Fields
RFC 2369
RFC 2369:List-Unsubscribe 和 List-* 头部
RFC 3834
RFC 3834: 电子邮件中的自动响应
RFC 6377
RFC 6377: DKIM 和邮件列表
RFC 6854
RFC 6854: From 和 Sender 报头字段中的组语法
RFC 8058
RFC 8058:电子邮件一键退订
DNS & Mail Routing
RFC 2181
DNS 规范的澄清
RFC 1912
常见 DNS 运维与配置错误
RFC 1034
域名:概念和设施
RFC 1035
RFC 1035 – 域名:实现与规范
RFC 5782
RFC 5782:基于DNS的黑名单和白名单
RFC 6186
RFC 6186:电子邮件服务自动发现的SRV记录
RFC 7505
域名无服务